Currently the constant
L1_CACHE_LINE_SIZE (for arm) is defined in two places [1,2]:
Can we move it to be generated as either:
- part of platform_gen.h
- or as a new per-cpu family header?
I’d like to define this, and other CPU related settings, in a single place as I need to define the constant for a new CPU family that is unlikely to be merged to master (as the device tree is proprietary) and I’d prefer to keep the patches.
Thoughts? I’m happy to implement it and put a PR up but I’d like it to be consistent with the current direction of configuration in the kernel. cc @kent.mcleod